March 23, 2017, 07:09:53 pm
News:
Pages: [1]
Print
Author Topic: XBMC and VDPAU issue  (Read 5885 times)
cyrus
Jr. Member
**
Posts: 74


View Profile
« on: April 08, 2010, 11:32:38 pm »

Anyone else successfully running XBMC and playing high quality (720p or greater) content under XBMC? This use to work no problem for me, now after some upgrade (I run Gentoo on my Link) it always crashes with messages from XBMC stating:

04:24:20 T:2303413104 M:1764716544  NOTICE: Creating audio device with codec id: 86020, channels: 2, sample rate: 48000, no pass-through
04:24:20 T:2311805808 M:1747099648  NOTICE:  (VDPAU) Didnt find a Video Surface Available (Total: 0). Creating a new one. TRY #1
04:24:20 T:2311805808 M:1745448960  NOTICE:  (VDPAU) FiniVDPAUOutput
04:24:20 T:2311805808 M:1745448960  NOTICE:  (VDPAU) screenWidth:1920 vidWidth:1280
04:24:20 T:2311805808 M:1745448960  NOTICE:  (VDPAU) screenHeight:1080 vidHeight:720
04:24:20 T:2311805808 M:1745350656   ERROR:  (VDPAU) Error: The system does not have enough resources to complete the requested operation at this time.(23) at VDPAU.cpp:938
04:24:20 T:2311805808 M:1745350656  NOTICE:  (VDPAU) Total Output Surfaces Available: 0 of a max (tmp: 4 const: 4)
04:24:20 T:2311805808 M:1745350656  NOTICE: VDPAU Decoder capabilities:
04:24:20 T:2311805808 M:1745350656  NOTICE: name          level macbs width height
04:24:20 T:2311805808 M:1745350656  NOTICE: ------------------------------------
04:24:20 T:2311805808 M:1745350656  NOTICE: MPEG1             0  8192  2048  2048
04:24:20 T:2311805808 M:1745350656  NOTICE: MPEG2_SIMPLE      3  8192  2048  2048
04:24:20 T:2311805808 M:1745350656  NOTICE: MPEG2_MAIN        3  8192  2048  2048
04:24:20 T:2311805808 M:1745350656  NOTICE: H264_MAIN        41  8190  2032  2048
04:24:20 T:2311805808 M:1745350656  NOTICE: H264_HIGH        41  8190  2032  2048
04:24:20 T:2311805808 M:1745350656  NOTICE: VC1_SIMPLE        1  8190  2048  2048
04:24:20 T:2311805808 M:1745350656  NOTICE: VC1_MAIN          2  8190  2048  2048
04:24:20 T:2311805808 M:1745350656  NOTICE: VC1_ADVANCED      4  8190  2048  2048
04:24:20 T:2311805808 M:1745350656   ERROR:  (VDPAU) Error: An invalid handle value was provided.(3) at VDPAU.cpp:1115
04:24:20 T:2311805808 M:1744592896  NOTICE:  (VDPAU) Didnt find a Video Surface Available (Total: 1). Creating a new one. TRY #1
04:24:20 T:2311805808 M:1753354240   ERROR:  (VDPAU) Error: An invalid handle value was provided.(3) at VDPAU.cpp:1115
04:24:20 T:2311805808 M:1753354240  NOTICE:  (VDPAU) Didnt find a Video Surface Available (Total: 2). Creating a new one. TRY #1
04:24:20 T:2311805808 M:1751830528   ERROR:  (VDPAU) Error: An invalid handle value was provided.(3) at VDPAU.cpp:1115

I have tried downgrading my nvidia-drivers and reverted to the latest release of XBMC but the issue still persists.
Logged
cyrus
Jr. Member
**
Posts: 74


View Profile
« Reply #1 on: April 09, 2010, 08:33:06 am »

Ah...it will never get any views over here  Angry

This really wasn't a Gentoo question but more a question of whether anyone else has experienced this issue.
Logged
ChadV
Administrator
Hero Member
*****
Posts: 1611


View Profile WWW
« Reply #2 on: April 09, 2010, 12:38:02 pm »

Yeah it will.  It shows up fine under "unread posts".  Smiley

I've not seen it or heard of anyone else having the problem, though...  Did you post over at XBMC's forums in case someone over there knew?  It doesn't seem to be hardware-specific at all...
Logged
cyrus
Jr. Member
**
Posts: 74


View Profile
« Reply #3 on: April 09, 2010, 07:53:30 pm »

I have posted in the forums and on IRC. The answer I always seem to get is that your system doesn't have enough memory to play the video. I have the full 512 allocated to the video card.
Logged
ChadV
Administrator
Hero Member
*****
Posts: 1611


View Profile WWW
« Reply #4 on: April 10, 2010, 08:48:01 am »

What's the resolution on the incoming file?  Is it only files over 720p, or every file after the upgrade, even SD?
Logged
cyrus
Jr. Member
**
Posts: 74


View Profile
« Reply #5 on: April 10, 2010, 12:18:40 pm »

Only files 720p and up.

What version of nvidia-drivers are you running?
Logged
cyrus
Jr. Member
**
Posts: 74


View Profile
« Reply #6 on: April 10, 2010, 09:36:13 pm »

I was looking for this today but couldn't find it. In the BIOS, where do I set the amount of memory for the IGP? nvidia-settings shows it is at 512 but I just want to confirm in the BIOS. I know I have seen this before, just can't find it now.
Logged
ChadV
Administrator
Hero Member
*****
Posts: 1611


View Profile WWW
« Reply #7 on: April 10, 2010, 11:14:53 pm »

I'm running v190 w/ vdpau, and it did work on the 720p file I tested, and with several really old codecs at 480.
Logged
cyrus
Jr. Member
**
Posts: 74


View Profile
« Reply #8 on: April 11, 2010, 12:44:08 pm »

I'm running v190 w/ vdpau, and it did work on the 720p file I tested, and with several really old codecs at 480.

You are runnign v190 w? What does that mean?
Logged
ChadV
Administrator
Hero Member
*****
Posts: 1611


View Profile WWW
« Reply #9 on: April 14, 2010, 08:33:17 am »

nVidia drivers version 190 with vdpau support.
Logged
Pages: [1]
Print
Jump to: