September 24, 2017, 09:41:29 pm
News:
Pages: [1]
Print
Author Topic: "Issues" with recording to SD card...  (Read 2942 times)
pfft2001
Sr. Member
****
Posts: 378



View Profile
« on: April 08, 2012, 10:18:37 am »

As you all know, I have long championed recording only to the network, since the USB doesn't work at all and the network is just more convenient overall (since you can get to the files from anywhere on your network).  However, today, while trying to debug/fix a long lingering problem, I decided to try recording to SD card again.  I ran into a couple of issues:

1) Since the card that I chose to use - an 8G SDHC card - had been partitioned in a funny way as part of another experiment (with the RPi, as it turns out), I repartitioned it and formatted it (on another Linux system) with "mke2fs".  I know that the OSD is most happy with media formatted FAT32, but I have been assured, by Neuros Tech Support (on the phone - back in the early days when they actually had phone tech support) that EXT2, being Linux's "native" file system, would work just as well - in fact, better in some ways than FAT32.  Well, the problem I ran into was that when I inserted the card, it failed to mount it.  I could tell from "dmesg" that it saw the card, but then generated some error messages indicating that it was trying to mount it as if it were FAT and it failed.  When I reformatted the card with "mkdosfs", it then worked as expected in the OSD.  Strange, eh?  Maybe that could be fixed in a future life...

2) (The real reason for this posting).  Once I had the card in the OSD and auto-mounted, I could see it as a choice in the Play.Browse dialogs, but *not* (and this is the truly strange part) in the Record.Schedule dialogs.  I could not find any way (using the GUI alone) to *record* to the SD card.  The only choices given were all of my network shares as well as the options for mounting new network shares.  There was nothing for either USB or SD-Card.

Now, two things:

....a) I seem to remember hitting this problem once long ago, before I had compiled SQLITE3, and finding some weird fix - some obscure option buried somewhere in the GUI.  I say "weird" because this is a bug, but there seemed to have been some weird workaround.  Note also that I did end up rebooting the OSD (with the SD card inserted) to see if that would fix anything, but it did not.

....b) I was able to fix this by brute force, for my scheduled recording(s), using SQLITE3 to modify the database directly.  This was a lifesaver, but this is obviously not ideal.  Also, I could still find no way (using the GUI) to do an "on the fly" recording to SD.  Note: I think I tried just about all the places in the GUI where you can set this; I even tried Tools -> Settings -> Default Recording -> SaveTo/Edit - but again, the only options presented were the network-oriented ones.

In conclusion, any help/advice anyone can give would be greatly appreciated.


Logged
ChadV
Administrator
Hero Member
*****
Posts: 1611


View Profile WWW
« Reply #1 on: April 08, 2012, 10:00:47 pm »

That's... really odd.  Since the only place I've ever recorded to was an 8GB SDHC card.

When you mount it now as FAT32, does dmesg give you any errors at all?  How about when you go to setup the recording?

Is it possible you have the little read-only toggle flipped?  (I always forget they have those...)
Logged
pfft2001
Sr. Member
****
Posts: 378



View Profile
« Reply #2 on: April 09, 2012, 08:45:48 am »

That's... really odd.  Since the only place I've ever recorded to was an 8GB SDHC card.

When you mount it now as FAT32, does dmesg give you any errors at all?  How about when you go to setup the recording?

Is it possible you have the little read-only toggle flipped?  (I always forget they have those...)

Well, I am able to record to the card - via the scheduler  and by using SQLITE3 to modify the path name stored in the database.  That is, I use SQL (the "update" command) to change it to: /media/SD-card/foo.mp4 and then the scheduled recording runs, creating a file on the SD card.  So, the problem is in the GUI, not in the underlying mechanics.  And it is obviously not a read-only problem.

Further, I'm sure that it does work - out of the box - it's just that somehow my GUI has gotten "wedged".  I've tried pressing the Xim key and hitting "refresh", but it doesn't help.  It seems like some kind of "refresh" operation is needed - something to make it re-scan the devices and re-populate the menu.  And, as I mentioned, I even tried rebooting, but it still didn't show up in the menus.

P.S.  As far as I can tell, there aren't any errors in "dmesg" (when the card is formatted FAT).  Of course, the logs are so chatty that it is sometimes hard to tell what's an error message and what isn't...

P.P.S.  Just out of curiosity, any idea why it didn't work as EXT2?
Logged
ChadV
Administrator
Hero Member
*****
Posts: 1611


View Profile WWW
« Reply #3 on: April 09, 2012, 12:04:18 pm »

Odd.  Especially since other devices still update the recording destinations...

No clue why EXT2 didn't work...  Maybe the partition table didn't match the format?
Logged
heyrick
Global Moderator
Sr. Member
*****
Posts: 340



View Profile WWW
« Reply #4 on: April 09, 2012, 12:10:44 pm »

As you all know, I have long championed recording only to the network,

Hmm, the one time I tried using the network, to say it was Epic Fail would be quite the understatement. I was not recording to a Windows share, only copying a file. Some five hours later, a gigabyte STILL had not transfered and helpfully as the OSD has this damn cut'n'paste metaphor, there was no indication of progress.
I aborted that (rebooting from telnet) and copied the file using my eeePC. A little over three minutes on the SAME network and to the SAME Windows share.

I've not tried recording to network.


Quote
1) Since the card that I chose to use - an 8G SDHC card - had been partitioned in a funny way as part of another experiment (with the RPi, as it turns out), I repartitioned it and formatted it ...big snip... I could tell from "dmesg" that it saw the card, but then generated some error messages indicating that it was trying to mount it as if it were FAT and it failed.  When I reformatted the card with "mkdosfs", it then worked as expected in the OSD.  Strange, eh?  Maybe that could be fixed in a future life...

Firstly, some formatters do not correctly (or at all?) modify the partition table. I'm used to this with having used harddiscs under RISC OS, that Windows will not always see them even if they're in FAT format. At the time, I figured the partition table was not being set up correctly, like the formatter was setting up the entry it needed while ignoring the rest?
If you recall, it was a two-step process under old DOS - fdisk then format. Anything that fiddles with the partition part needs the fdisk part, a format is not enough. I think modern Windows is smarter, but there's still the possibility of strangeness.

While the OSD can use extfs partitions, being Linux, and yes - just about everything except recording to post-it notes is better than crappy FAT - does it probe inserted media, or does it just assume it'll be FAT? This assumption will be correct for 99% of the users, which could be why it might just assume FAT?


Quote
I could not find any way (using the GUI alone) to *record* to the SD card.  The only choices given were all of my network shares as well as the options for mounting new network shares.  There was nothing for either USB or SD-Card.

These things only appear when relevant. For example, I don't use USB any more so I don't see a USB option. As to why it appears somewhere but not somewhere else, sounds like a bug?


FWIW - I record to SD. Either 16GiB or 32GiB cards. I used to record to USB but there's a levy {*} on blank media which for some reason makes USB devices inordinately pricey unless you want a big pile of 4GiB devices. My cards are either used as-purchased or formatted on Windows. Never reformatted to something else.

* - a levy on blank media and HADOPI laws making copying media an offence, don't get me started on who the real freetards are...


Best wishes,

Rick.
Logged
pfft2001
Sr. Member
****
Posts: 378



View Profile
« Reply #5 on: April 09, 2012, 12:39:13 pm »

Oops - in the "My face is red" department...

What you have to do, after pressing "Edit" (nex to the "Save To" box) is to press the left-arrow key.  This takes you back to the "SD card", "Shortcuts", "Network Shares" screen.  Sorry for the waste of bandwidth...

So, that's the main issue solved.  However, the other points raised in this thread still stand.  Note to Rick: I did the partitioning/formatting on a Linux system - so any Windows-centric assumptions you may have made are irrelevant.  I used Linux "fdisk" and "mke2fs" and "mkdosfs".  Note also (to Chad) that in all cases, the "type" field in the partition table was left at 83 (Linux native).  Very little software actually cares what you put here.

And, yes, it does seem that it just assumes the filesystem on the card is FAT and uses FAT-specific mount options when trying to mount it.  A shame, really...  Note (not surprisingly) that I can, of course, mount the card manually from the shell prompt, and it mounts just fine as EXT2.
Logged
Pages: [1]
Print
Jump to: